Print the following pattern

Pattern for N = 4

The dots represent spaces.



Input Format :
N (Total no. of rows)
Output Format :
Pattern in N lines
Sample Input :
5
Sample Output :

The dots represent spaces.



code:

#include<iostream>
using namespace std;


int main(){

 int n, num = 1, space;
  cin>>n;
 
  space = n - 1;
 
  for (int i = 1; i <= n; i++)
  {
    num = i;
 
  for (int j = 1; j <= space; j++)
    cout<<" ";
 
  space--;
 
  for (int j = 1; j <= i; j++)
  {
    cout<<num;
    num++;
  }
cout<<endl;  
}

  
}



SHARE

Milan Tomic

Hi. I’m Designer of Blog Magic. I’m CEO/Founder of ThemeXpose. I’m Creative Art Director, Web Designer, UI/UX Designer, Interaction Designer, Industrial Designer, Web Developer, Business Enthusiast, StartUp Enthusiast, Speaker, Writer and Photographer. Inspired to make things looks better.

  • Image
  • Image
  • Image
  • Image
  • Image
    Blogger Comment
    Facebook Comment

0 comments:

Post a Comment